Exchange Server 2010 – SP3 Fallstricke

(Dieser Beitrag wurda am 26. Oktober 2020 aktualisiert.)

Beim Update eines Exchange Server von "Pre SP3" auf das SP3 (14.03.0123.004), bin ich über einige Fallstricke gestolpert…
Wie sich herausstellte wurde der Server hinsichtlich Konfiguration und Wartung schwer vernachlässigt, eigentlich stimmte gar nichts, aber "irgendwie" ging es…

  1. Fehler beim Update der CAS Rolle:
    "The certificate with thumbprint 355E62E46xxxxxxxxxxxx42B760E was not found."

    Total simple Geschichte, aber der Kunde hatte zwar artig sein Zertifikat am IIS gebunden, allerdings wusste der Exchange nichts davon…
    Mit einem simplen

    Get-ExchangeCertificate | ft name,thumb*,services

    prüfte ich die Zertifikatsbindungen des Exchange und siehe da, hier waren "offiziell" nur POP und IMAP gebunden…
    Da wir den Thumbprint schonmal hatten, gleich kopiert und mit einem

    Enable-ExchangeCertificate -Thumbprint 355E62E46xxxxxxxxxxxx42B760E -Services IIS,SMTP,POP,IMAP

    das Zertifikat korrekt gebunden. Dann noch den IIS mit

    iisreset

    neu gestartet und auf in den nächsten Fallstrick…

  2. Fehler bei der Hub Transport Rolle:
    "A failure occurred while trying to update metabase properties."

    Schon etwas "komischer" aber bei Exchange gibts halt alles. Das Update fällt komischerweise über das PowerShell Virtual Directory…
    Folgende Tasks, dann lief auch das Update:

    1. Starte adsiedit.msc und verbinde die Konsole mit der Konfigurationspartition
    2. Suche nach Services\Microsoft Exchange\Administrative Groups\DEINE Administrative Gruppe\Server\Protocols\HTTP
    3. Suche auf der rechten Seite nach dem Eintrag für das PowerShell Virtual Directory und lösche dieses! (klingt komisch, is aber so…)
    4. Dann am IIS nach dem virtuellen Verzeichnis der PowerShell suchen und falls es noch da ist, ebenfalls löschen
    5. Wieder einen
      iisreset
    6. Server neu gestartet und bei mir lief das Update dann sauber durch…