ESXi Update – MISSING_DEPENDENCY_VIBS_ERROR

Bei einem Inplace Upgrade von ESXi 6.7 auf 7.0 stolperte ich über diesen Fehler:

Offensichtlich blockierte ein inkompatibles Package (in meinem Fall der Nimble Network Connection Manager für das Multipathing) den Update Prozess. Bitte nutzt die Pfeiltasten wirklich, um zu scrollen, denn es können mehrere VIBs dafür verantwortlich sein. Dieses Paket galt es also zu entfernen, um den Update Prozess abschließen zu können. Hierzu wird der Server zunächst mit F11 neu gestartet. Anschließend via SSH auf den Server verbinden…

betreffendes VIB finden (laut Screenshot irgendwas mit „Nimble…“:

esxcli software vib list | grep -i Nimble

betreffendes Paket (hier also „nimble-psp“) entfernen:

esxcli software vib remove -n nimble-psp

Vollständig sieht das Ergebnis dann so aus:

Anschließend noch ein Reboot des Servers und das Update kann weitergehen.

Falls speziell dieses Plugin nach dem Upgrade wieder installiert werden soll, könnte dieser Beitrag interessant sein.

Beitrag Teilen

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert

Diese Seite ist durch reCAPTCHA und Google geschütztDatenschutz-Bestimmungen UndNutzungsbedingungen anwenden.